GGC Internet Maintenance - April 14th @ 10:30pm

Scheduled for Apr 14, 10:30 - 11:30 EDT

Update

We will be undergoing scheduled maintenance during this time.
Posted Apr 09, 2026 - 14:24 EDT

Scheduled

GGC will be performing maintenance on the campus Internet connection starting at 10:30pm. While we do not expect any downtime, there may be a momentary pause that could last a few seconds. This pause would only effect people on campus or connecting via VPN.
Posted Apr 09, 2026 - 14:22 EDT
This scheduled maintenance affects: Network (VPN, PeachNet).