Student Payment System Outage

Incident Report for GGC

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 14:57 EDT

Identified

We are currently investigating the issue with the student payment systems (TouchNet).
Posted Apr 08, 2026 - 11:36 EDT
This incident affected: Productivity Tools (TouchNet).