Microsoft Team Issues
Incident Report for GGC
Resolved
After extended monitoring, various optimizations, and mitigation efforts, Microsoft has confirmed Teams service and features have been restored or have returned to optimal health.
Posted Jan 29, 2024 - 08:09 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 27, 2024 - 23:05 EST
Investigating
Microsoft is currently investigating an issue impacting multiple Microsoft Teams features.
Posted Jan 26, 2024 - 12:46 EST
This incident affected: Communication & Collaboration Tools (Microsoft Teams).