MyCourses Email Attachment Issues

Incident Report for GGC

Resolved

USG Information Technology Services (ITS) has confirmed that MyCourses email is functioning normally at this time.
Posted Sep 21, 2023 - 08:54 EDT

Investigating

USG Information Technology Services (ITS) and our vendor are investigating issues with MyCourses email attachments.
Posted Sep 20, 2023 - 18:59 EDT
This incident affected: Teaching & Learning (MyCourses).