Softphone numbers are unable to receive calls including the Enrollment Communication Services Department/Call Center

Incident Report for GGC

Resolved

This incident has been resolved.
Posted Mar 25, 2026 - 08:57 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 23:16 EDT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2026 - 23:16 EDT

Update

Information Technology (IT) is working with our vendors to further investigate this issue.
Posted Mar 24, 2026 - 19:04 EDT

Investigating

We are currently investigating this issue.
Posted Mar 24, 2026 - 15:02 EDT
This incident affected: Telephone Systems (Softphones).