Resident Life Network Slowness

Incident Report for GGC

Update

We are continuing to monitor for any further issues.
Posted Apr 09, 2026 - 17:16 EDT

Monitoring

We have isolated the cause to a bad network port and have performed remediation steps. We are now monitoring the network traffic to measure the effectiveness of the repair.
Posted Apr 09, 2026 - 17:15 EDT

Investigating

We have received reports of slowness on the Resident Life network. We are investigating the issue.
Posted Apr 09, 2026 - 16:00 EDT
This incident affects: Network (Wireless (GGC Wifi, GGC Guest, & eduroam)).