GGC ITEC Network Packet Loss

Incident Report for GGC

Resolved

The root cause was identified and corrected. Duplicate IP address was assigned to equipment in the ITEC network.
Posted May 05, 2026 - 13:45 EDT

Investigating

We are aware of reports of network slowness and packet loss for the ITEC networks on campus. We are investigating the cause.
Posted May 05, 2026 - 13:26 EDT
This incident affected: Network (Wired).