Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 25, 2025 - 18:00 EDT
Scheduled
The Information Technology team will be performing network maintenance in Building D in network closets A and B. The schedule time is from Friday April 25th @ 6pm to Saturday April 26th @ 2am.
Affected areas: 1st floor rooms 1200-1499 which includes Testing Center, Claw Card, Call Center, New Student Connections, Admissions, and Registration Services 2nd floor rooms 2100-2108
Non-Affected Areas Campus Police Department – rooms 1501-1599 Welcome Center and adjacent rooms 1100-1199
Affected Services: Internet/Peachnet Wired/wireless network Desk phones Printing and Scanning
Posted Apr 23, 2025 - 17:25 EDT
This scheduled maintenance affected: Network (Wired, Wireless (GGC Wifi, GGC Guest, & eduroam), PeachNet), Communication & Collaboration Tools (Claw Mail, Microsoft Teams, Microsoft Office 365, Microsoft OneDrive / SharePoint), Telephone Systems (Office & Desk Phones), and Productivity Tools (Printing & Scanning).