Some users may experience issues accessing Claw Mail.
Incident Report for GGC
Resolved
This incident has been resolved.
Posted Apr 10, 2024 - 12:53 EDT
Investigating
We are working on a solution and updates will be posted when available. For now, use MS Edge or Incognito mode for Google Chrome.
Posted Apr 05, 2024 - 13:48 EDT
This incident affected: Communication & Collaboration Tools (Claw Mail).