Microsoft M365 Service Issues

Incident Report for GGC

Resolved

This incident has been resolved.
Posted Jan 23, 2026 - 05:32 EST

Update

We are continuing to monitor for any further issues.
Posted Jan 22, 2026 - 22:10 EST

Monitoring

User impact: Users may be seeing degraded service functionality or be unable to access multiple Microsoft 365 services. These issues are affecting timely delivery of email messages in Claw Mail/Outlook as well as some features in MS Teams. Microsoft is working to resolve the issues as quickly as possible.
Posted Jan 22, 2026 - 22:10 EST
This incident affected: Communication & Collaboration Tools (Claw Mail, Microsoft Teams, Microsoft Office 365, Microsoft OneDrive / SharePoint).