Zoom experienced a global outage this evening, which has affected the Zoom integration in MyCourses. The GGC Zoom web portal (https://ggc-edu.zoom.us/) is now working.
IT recommends that instructors start any previously scheduled class meetings from the web portal until the integration has been restored. Your scheduled meetings will appear under the Upcoming tab in the Meetings section of your account. Be sure to post an announcement in your course with the Zoom meeting link to ensure students know how to join the meeting. An announcement has been posted in MyCourses with additional details.
We are working closely with vendor support to resolve this issue as soon as possible. Please keep checking the GGC Status page for updates and contact helpdesk@ggc.edu if you encounter any problems or have questions.
Posted Apr 16, 2025 - 21:00 EDT
Update
We are continuing to investigate this issue.
Posted Apr 16, 2025 - 20:58 EDT
Investigating
It's reported that Zoom is currently experiencing a global outage. Users have reported various issues, including difficulties logging into meetings, accessing the site, and modifying settings.
Posted Apr 16, 2025 - 16:47 EDT
This incident affected: Communication & Collaboration Tools (Zoom).