Email Delivery Delayed
Incident Report for GGC
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 17:07 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 09, 2024 - 13:23 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 09, 2024 - 06:48 EST
Investigating
The email server has been affected by a large spam campaign. Information Technology (IT) is working to clear the mail queue and restore performance to normal levels. In the meantime, delivery of some email messages will be delayed.
Posted Feb 09, 2024 - 06:45 EST
This incident affected: Communication & Collaboration Tools (Claw Mail).