There is a network issue impacting C2230, C2240, and C2250
Incident Report for GGC
Resolved
This incident has been resolved.
Posted Jan 08, 2024 - 12:32 EST
Investigating
We are currently investigating this issue.
Posted Jan 08, 2024 - 09:47 EST
This incident affected: Network (Wired).