Network Outage in Building A affecting the Help Desk.

Incident Report for GGC

Resolved

This incident has been resolved.
Posted Jul 23, 2025 - 18:23 EDT

Investigating

We are currently investigating an issue with the Network in Building A. Currently, the Help Desk has limited access to the Ticketing System.
Posted Jul 23, 2025 - 13:25 EDT
This incident affected: Help Desk Portal.