Domains Site Outage

Incident Report for GGC

Resolved

This incident has been resolved.
Posted Mar 30, 2026 - 13:01 EDT

Identified

Vendor contacted and is currently migrating to a new server to address recent instability and prevent future downtime. The site will be offline briefly during this emergency maintenance window.
Posted Mar 30, 2026 - 11:32 EDT

Investigating

We are currently investigating this issue.
Posted Mar 30, 2026 - 11:19 EDT
This incident affected: Teaching & Learning (domains.ggc.edu).