Degraded Office & Desk Phones
Incident Report for GGC
Resolved
The issues with call quality on the office and desk phones has been resolved. The phone system and communications network were rebooted. Test calls indicated no further degradation of quality.
Posted Apr 19, 2024 - 09:21 EDT
Investigating
We are currently investigating this problem. We have escalated this issue to our phone vendor and Internet Service Provider for further investigation.
Posted Apr 18, 2024 - 14:51 EDT
This incident affected: Telephone Systems (Office & Desk Phones).