Turnitin AI detection unavailable
Incident Report for GGC
Resolved
This incident has been resolved.
Posted Jan 16, 2025 - 13:59 EST
Investigating
Information Technology (IT) is investigating issues with the Turnitin AI detection feature in MyCourses. At this time, faculty will not be able to see an AI score in the Turnitin Similarity Report. IT is working directly with Turnitin Support. Additional details will be provided as they become available.
Posted Jan 16, 2025 - 10:53 EST
This incident affected: Teaching & Learning (Turnitin).