OneUSG Connect

Incident Report for GGC

Resolved

This incident has been resolved.
Posted Mar 23, 2026 - 16:15 EDT

Investigating

OneUSG Connect is experiencing issues with the main page after logging in. The issue has been reported to USG's Help Desk. We've noticed the issue happens more on Microsoft Edge, and Google Chrome browsers, and the Firefox browser seems to be OK.
Posted Mar 23, 2026 - 09:11 EDT
This incident affected: OneUSG Connect (oneusgconnect.usg.edu).