Yuja Panorama Outage

Incident Report for GGC

Resolved

This incident has been resolved.
Posted May 07, 2026 - 14:17 EDT

Investigating

We are investigating a widespread service disruption with Yuja. Users may be unable to access any Yuja-hosted tools or resources at this time. We are aware that Yuja’s official status reporting is also offline, and our team is working to establish a timeline for resolution.
Posted May 07, 2026 - 13:33 EDT
This incident affected: Teaching & Learning (Panorama).