OneUSG Connect Issues Reported

Incident Report for GGC

Resolved

This incident has been resolved.
Posted May 07, 2026 - 20:44 EDT

Monitoring

OneUSG Connect Support has restored full functionality of access to OneUSG Connect. We will continue to monitor this system for stability. If you are still experiencing issues with access to OneUSG Connect, please contact the USG Service Desk at support@usg.edu or 877-251-2644.
Posted May 07, 2026 - 08:49 EDT

Investigating

OneUSG Connect is currently experiencing an unexpected outage and is unavailable. We are working closely with the University System of Georgia (USG) to monitor the situation. For immediate questions or concerns, you may also reach out to the USG Service Desk directly at support@usg.edu
Posted May 07, 2026 - 08:00 EDT
This incident affected: OneUSG Connect (oneusgconnect.usg.edu).