Listserv Outage
Incident Report for GGC
Resolved
Listserv is operational. The issue has been resolved.
Posted Jan 25, 2024 - 08:58 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 24, 2024 - 13:15 EST
Investigating
Listserv service is experiencing an outage. The IT team is working to identify and resolve the problem. Estimated time to resolution is not known at this time. Please stay tuned for updates. Thank you!
Posted Jan 24, 2024 - 10:59 EST
This incident affected: Communication & Collaboration Tools (LISTSERV).