Between approximately 3:00 a.m. and 5 p.m. on Monday, October 20, 2025, many services such as MyCourses, Kaltura, Respondus LockDown Browser/Monitor, and Simple Syllabus experienced intermittent issues due to an Amazon Web Services (AWS) outage.
AWS functionality has been restored. Some services may still experience issues as backlogged processes finish over the next few hours.
IT and our vendors will continue monitoring.
Posted Oct 20, 2025 - 19:06 EDT
Update
We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 11:18 EDT
Identified
Many services such as MyCourses, Kaltura, Respondus Lockdown Browser/Monitor, and Simple Syllabus are experiencing performance related issues due to a global outage impacting Amazon Web Services (AWS). Thank you for your patience while AWS works to resolve this issue.
Posted Oct 20, 2025 - 11:17 EDT
This incident affected: Teaching & Learning (MyCourses, Kaltura, Respodus Lockdown Browser and Monitor, Simple Syllabus).